Install the latest node.js version on your Raspberry Pi

Install the latest node.js version on your Raspberry Pi

When you install Node.js on your Raspberry Pi via:

sudo apt-get install npm

Apt installs an old version of Node.js. I ended up with version v0.6.19 instead of the latest v0.10.26. The ARM build is always some behind on the x86 version, but this ancient version broke some of my needed packages.

To install the latest ARM Node.js we need to download the latest Debian package manually:

sudo wget http://node-arm.herokuapp.com/node_latest_armhf.deb

and manually install the package:

sudo dpkg -i node_latest_armhf.deb

You can verify your Node.js version via:

node -v

Which should output something like:

v0.10.26

After installing this new Node.js version. Npm kept complaining about the old version:

npm ERR! Unsupported
npm ERR! Not compatible with your version of node/npm: [email protected]
npm ERR! Required: ["node >= 0.8.0"]
npm ERR! Actual:   {"npm":"1.1.4","node":"0.6.19"}

After a reboot of the Raspberry Pi this problem was solved and the correct version was detected.

Leave a Reply

Your email address will not be published. Required fields are marked *